• Advertisement
Xclusively Jaguar
SNG Barratt
David Marks Garages
Make a donation to XJ40.com

1990 Daimler Auto problems

david
Posts: 6582
Joined: Wed Aug 06, 2008 8:09 pm
Location: Cheshire, UK

Re: 1990 Daimler Auto problems

Postby david » Wed Jan 19, 2011 1:32 am

I hope the 'box on your 3.2 is all right, Rob.

The 4 litre engine can always be spotted by its lack of a throttle cable, Derek. The 3.2 and 3.6 look very similar with a cable, the 4 litre just has the spring.

Graham's (gafj's) Daimler with the 4 litre electronic box; no cable, just electronically controlled luxury.

Image

My 3.2. You can see the control cable on the right side of the throttle coupling.

Image


David
Image 1992 Sovereign 3.2 diamond blue (1993 model)

S1VART

Re: 1990 Daimler Auto problems

Postby S1VART » Wed Jan 19, 2011 3:22 am

I drove it again last night for about a 30 minute run , it drove OK , no limp mode

the oil is fresh, but I doubt if the filter had been changed , and very clean , I did notice that it has been changed to a external oil cooler instead of running through the radiator,

I haven't checked the throttle position sensor , I might reset the error codes and clean the auto sensors also , with another auto oil / filter change

mine is the 4.0ltr like in the first picture

thanks for all the advice so far

old del boy
Posts: 6916
Joined: Thu Jul 10, 2008 9:29 am
Location: Kent

Re: 1990 Daimler Auto problems

Postby old del boy » Mon Jan 24, 2011 2:31 am

XJ40-MARK wrote:
XJ40-MARK wrote:
david wrote:I hope the 'box on your 3.2 is all right, Rob.

The 4 litre engine can always be spotted by its lack of a throttle cable, Derek. The 3.2 and 3.6 look very similar with a cable, the 4 litre just has the spring.

Graham's (gafj's) Daimler with the 4 litre electronic box; no cable, just electronically controlled luxury.

Image



David


wow, something else i`ve learned :D
did`nt know this!


whats the single cable on the 4.0 for then derek, the cruise control?


David was commenting on the lack of the kickdown cable on an electronic gearbox , the single cable is the throttle cable which they all have ,

Derek..
'93 4.0L Daimler, solent blue,
'93 4.0L Daimler, Westminster,
'85 2600 Rover sd1 vdp oporto.

xj12-rob
XJ40 Guru
Posts: 5900
Joined: Sat Jul 05, 2008 4:12 pm
Location: SCOTTISH BORDERS

Re: 1990 Daimler Auto problems

Postby xj12-rob » Mon Jan 24, 2011 12:46 pm

update on my old 3.2, litre of ATF added, where it had gone god knows, PAS topped up, all good quite as mouse, no leaks, way hey off we go again, had friends from Finland here over the weekend, used it instead of the Vectra, illegal speeds down the A1 again!!, great fun
if it ain't sideways, it ain't serious
93 XJ12
93 XJ12 SPORT
93 XJ12 SPARESx2
94 3.2 GOLD MAJESTIC
94 4.0 SOV MAJESTICx2
94 4.0 INSIGNIA
94 XJR MANUAL
97 XJR MANUALx2
93 XJ6 3.2 PAINT TEST CAR
06 X350 XJR

S1VART

Re: 1990 Daimler Auto problems

Postby S1VART » Mon Feb 07, 2011 5:19 am

Im just about to do all the cleaning and changing , but cant find a adjustment settings for the TPS , most Mitsubishi ones are usually 0.50V , does anyone know the setting for the 4.0 90 Daimler setup ?

I drove the car around a few days ago it felt really powerless, it has its good days and bad days

old del boy
Posts: 6916
Joined: Thu Jul 10, 2008 9:29 am
Location: Kent

Re: 1990 Daimler Auto problems

Postby old del boy » Mon Feb 07, 2011 12:00 pm

S1VART wrote:Im just about to do all the cleaning and changing , but cant find a adjustment settings for the TPS , most Mitsubishi ones are usually 0.50V , does anyone know the setting for the 4.0 90 Daimler setup ?

I drove the car around a few days ago it felt really powerless, it has its good days and bad days


I believe the signal wire [wiper] should range from 0.2 - 0.5 to 4.8 v ,

Derek..
'93 4.0L Daimler, solent blue,
'93 4.0L Daimler, Westminster,
'85 2600 Rover sd1 vdp oporto.

Mashjag
Posts: 1
Joined: Wed Dec 12, 2018 1:25 pm

Re: 1990 Daimler Auto problems

Postby Mashjag » Thu Dec 20, 2018 11:27 pm

Does anyone know what the brown plug to the left of the battery is on the 4.0l picture. Only asking as mine is unplugged and bypassed!

Kind regards.
Matthew.