• Advertisement
Xclusively Jaguar
SNG Barratt
David Marks Garages
Make a donation to XJ40.com

XJ40 4.0 low coolant sensor

Oldbaldbiker
Posts: 6
Joined: Tue Apr 30, 2019 9:01 am
Location: Brisbane, Australia

XJ40 4.0 low coolant sensor

Postby Oldbaldbiker » Mon May 27, 2019 9:29 am

Hi all,

Just joined, as just purchased 2 XJ40’s. Only had Ser 1,2 &3 before, apart from a V8 250.

The dash light for the low coolant sensor is showing on my 4.0. Is there any way of testing the sensor to see if it is actually faulty? Are there any workarounds or repairs that can be done to these, rather than purchasing a new one?

Still trying to work out how to post a picture!

Cheers

Chris

xj40 paul
Snr Member
Posts: 221
Joined: Fri Jun 12, 2015 8:20 pm
Location: Birmingham

Re: XJ40 4.0 low coolant sensor

Postby xj40 paul » Mon May 27, 2019 10:19 am

Try this link if its working , its what I came across in my 1988 40 , regards Paul .

viewtopic.php?f=23&t=998692#p186489
Paulus The Wood Gnome .
1988 Jaguar 3.6 .
2000 Range Rover P38 DSE daily driver .

stevemc
Web Master
Posts: 789
Joined: Thu Jul 24, 2014 8:13 pm
Location: north wales
Contact:

Re: XJ40 4.0 low coolant sensor

Postby stevemc » Mon May 27, 2019 12:21 pm

xj40 paul wrote:Try this link if its working , its what I came across in my 1988 40 , regards Paul .

viewtopic.php?f=23&t=998692#p186489


its working :)
Jaguar xj40 1986 build D513 NBU vin number ends 504501
Audi A4 Sline 2016

naki_k
Super Moderator
Posts: 28679
Joined: Sun Feb 21, 2010 9:25 pm
Location: Kirton, nr Boston, Lincolnshire

Re: XJ40 4.0 low coolant sensor

Postby naki_k » Mon May 27, 2019 12:22 pm

xj40 paul wrote:Try this link if its working , its what I came across in my 1988 40 , regards Paul .

viewtopic.php?f=23&t=998692#p186489


Those are specific to the 86-89 models.
90-94 3.2/4.0/6.0 use a entirely different part.

I would suggest removing the sensor. It’s on a bayonet fitting. They are quite fragile though. You may find it’s actually broken in two already, or obviously damaged in some way.
Do check the plug and wiring too, to be through.

I have spares here if needed. PM for details.
88 3.6 XJ6 PDH/CEM
90 Range Rover Vogue SE 3.9 V8 LPG
91 4.0 XJ6 Manual
92 4.0 XJR Manual
92 4.0 XJR
93 3.2s - 4.0 Manual conv
93 4.0 Sovereign
93 6.0 XJ81 DD6 x2
93 6.0 XJ81 XJ12
94 4.0 XJR
94 4.0 Daimler
96 4.0 X306 XJR
96 4.0 X300 D6
97 4.0 X300 Sport Manual
2000 LR Discovery ES TD5 A
Breaking 40/ 300

katar83
Posts: 2767
Joined: Tue Aug 23, 2011 11:17 am
Location: Cambridge

Re: XJ40 4.0 low coolant sensor

Postby katar83 » Mon May 27, 2019 1:32 pm

I bet it's the bit in the tank itself that fallen out or is stuck :)
1997, 4.0 LWB X300 - Unlucky car but still a daily driver.
1988, 3.6S XJS - Never ending restoration project.
1994, 3.2S X300 - Accident damaged, October 2015. Gone!
1994, 3.2S XJ40 - Long gone.

Oldbaldbiker
Posts: 6
Joined: Tue Apr 30, 2019 9:01 am
Location: Brisbane, Australia

Re: XJ40 4.0 low coolant sensor

Postby Oldbaldbiker » Mon May 27, 2019 1:48 pm

Thanks for all the advice - will check them out tomorrow. Can I remove the sensor from the tank, keep it connected and immerse the sendor in a container of water to see if the light goes out?

xj40 paul
Snr Member
Posts: 221
Joined: Fri Jun 12, 2015 8:20 pm
Location: Birmingham

Re: XJ40 4.0 low coolant sensor

Postby xj40 paul » Mon May 27, 2019 3:41 pm

stevemc wrote:
xj40 paul wrote:Try this link if its working , its what I came across in my 1988 40 , regards Paul .

viewtopic.php?f=23&t=998692#p186489


its working :)

Nice one steve , that's the first ever time I have forwarded a link on here & didn't know if I was doing it right , I'll try posting a picture next & see if I can bugger that up :oops:
Paulus The Wood Gnome .
1988 Jaguar 3.6 .
2000 Range Rover P38 DSE daily driver .

naki_k
Super Moderator
Posts: 28679
Joined: Sun Feb 21, 2010 9:25 pm
Location: Kirton, nr Boston, Lincolnshire

Re: XJ40 4.0 low coolant sensor

Postby naki_k » Mon May 27, 2019 6:07 pm

Oldbaldbiker wrote:Thanks for all the advice - will check them out tomorrow. Can I remove the sensor from the tank, keep it connected and immerse the sendor in a container of water to see if the light goes out?


I do not think it’s that simple. I think there’s a float and magnet set up inside the tank that this sensor reads off. When you remove it you will see what I mean.
88 3.6 XJ6 PDH/CEM
90 Range Rover Vogue SE 3.9 V8 LPG
91 4.0 XJ6 Manual
92 4.0 XJR Manual
92 4.0 XJR
93 3.2s - 4.0 Manual conv
93 4.0 Sovereign
93 6.0 XJ81 DD6 x2
93 6.0 XJ81 XJ12
94 4.0 XJR
94 4.0 Daimler
96 4.0 X306 XJR
96 4.0 X300 D6
97 4.0 X300 Sport Manual
2000 LR Discovery ES TD5 A
Breaking 40/ 300

katar83
Posts: 2767
Joined: Tue Aug 23, 2011 11:17 am
Location: Cambridge

Re: XJ40 4.0 low coolant sensor

Postby katar83 » Mon May 27, 2019 8:01 pm

Correct. There is a float inside the tank with a little magnet thingy. Its possible the sensor itself came off the tank, mine did it few times but like I said sometime the little magnet or float inside comes off its resting place and you'd have to be very lucky to get it back in there without splitting the tank. In that case its usually easier to replace the whole tank.
1997, 4.0 LWB X300 - Unlucky car but still a daily driver.
1988, 3.6S XJS - Never ending restoration project.
1994, 3.2S X300 - Accident damaged, October 2015. Gone!
1994, 3.2S XJ40 - Long gone.

Oldbaldbiker
Posts: 6
Joined: Tue Apr 30, 2019 9:01 am
Location: Brisbane, Australia

Re: XJ40 4.0 low coolant sensor

Postby Oldbaldbiker » Mon Jun 10, 2019 11:31 am

Hi all,

Many thanks for all the helpful suggestions.

Just an update: While the warning light comes on initially, it now goes off once the engine reaches normal operating temperature. Not sure if this is normal, but am happy to live with this!

Next task: fixing the blower motor, which is not blowing at low or medium speed - found a really good step by step instructions on this site!

Cheers

Chris