• Advertisement
Xclusively Jaguar
SNG Barratt
David Marks Garages
Make a donation to XJ40.com

Front heated windscreen

katar83
Distinguished Mbr
Posts: 2434
Joined: Tue Aug 23, 2011 11:17 am
Location: Cambridge

Front heated windscreen

Postby katar83 » Mon Jul 04, 2016 2:00 pm

Anyone here, either with a late 40, 300 or 308 has the heated front windscreen? My windscreen got damaged couple of months ago, I already fitted the ac controls with the extra button before it happened and today got my windscreen replaced with the heated one. I've ordered the extra harness with two relays, just not sure where to plug it in into the main harness.
Would be great if someone could follow up the connectors under bonnet and let me know where it hides into the bulkhead.
1997, 4.0 LWB X300 - Unlucky car but still a daily driver.
1988, 3.6S XJS - Never ending restoration project.
1994, 3.2S X300 - Accident damaged, October 2015. Gone!
1994, 3.2S XJ40 - Long gone.

katar83
Distinguished Mbr
Posts: 2434
Joined: Tue Aug 23, 2011 11:17 am
Location: Cambridge

Re: Front heated windscreen

Postby katar83 » Tue Jul 05, 2016 9:22 pm

I did some more digging and eventually found a rubber blanking grommet in the left side engine bay corner that opens inside the car.
In the left side footwell, found these:

https://goo.gl/photos/HuXqkWLYSah3k3ai8

and including the plug from the extra harness I got that suppose to be ok for my VIN:

https://goo.gl/photos/Cmb4h7YjrPM1rwdDA

Now I'm wondering whether these can be paired and if its just the plug from the extra harness that is wrong and I needed an older version of it with two plugs that are no longer available :roll:
1997, 4.0 LWB X300 - Unlucky car but still a daily driver.
1988, 3.6S XJS - Never ending restoration project.
1994, 3.2S X300 - Accident damaged, October 2015. Gone!
1994, 3.2S XJ40 - Long gone.

david
Distinguished Mbr
Posts: 6558
Joined: Wed Aug 06, 2008 8:09 pm
Location: Cheshire, UK

Re: Front heated windscreen

Postby david » Tue Jul 05, 2016 11:06 pm

katar83 wrote:Anyone here, either with a late 40, 300 or 308 has the heated front windscreen? My windscreen got damaged couple of months ago, I already fitted the ac controls with the extra button before it happened and today got my windscreen replaced with the heated one. I've ordered the extra harness with two relays, just not sure where to plug it in into the main harness.
Would be great if someone could follow up the connectors under bonnet and let me know where it hides into the bulkhead.



Is this for an X300? - The XJ40 has a grey plug on either side of the engine compartment near the bonnet catch - the windscreen plugs plug into them, with the wire running from the corners of the screen over the plenum top on each side.

To be honest, I am not sure I understand your question! :oops:

If it is for an XJ40, do you want me to take photos to show how it plugs in on the '40?
Image 1992 Sovereign 3.2 diamond blue (1993 model)

david
Distinguished Mbr
Posts: 6558
Joined: Wed Aug 06, 2008 8:09 pm
Location: Cheshire, UK

Re: Front heated windscreen

Postby david » Tue Jul 05, 2016 11:20 pm

I have just noticed this is even in the X300 section! Am I blind! :lol:
Image 1992 Sovereign 3.2 diamond blue (1993 model)

katar83
Distinguished Mbr
Posts: 2434
Joined: Tue Aug 23, 2011 11:17 am
Location: Cambridge

Re: Front heated windscreen

Postby katar83 » Tue Jul 05, 2016 11:31 pm

Yes David, its for 300 but I believe the 40 is the same!

Yes, there are plugs for the windscreen in both corners but the harness for the heated windscreen that include these two sockets is optional and plugs into the main harness! I'm just not sure where!
It appears I have bought the later version of it that has a wrong type plug 4 wire one, instead of 2 plugs with two wires each as per my pic and at the end where it suppose to plug into the main harness. Just wondering whether anyone here has these plugs connected in a 40 or 300 in the left side foot well and maybe know that they are actually for the heated windscreen :)

By the way, the extra harness is part no LNB3090AA
1997, 4.0 LWB X300 - Unlucky car but still a daily driver.
1988, 3.6S XJS - Never ending restoration project.
1994, 3.2S X300 - Accident damaged, October 2015. Gone!
1994, 3.2S XJ40 - Long gone.

carsie
Snr Member
Posts: 742
Joined: Wed Apr 28, 2010 10:53 pm
Location: Suffolk
Contact:

Re: Front heated windscreen

Postby carsie » Wed Jul 06, 2016 9:13 am

Morning Katar :)

Its nice in sunny across here today isn't it?

Just picked up on your post- my XJR has a heated front screen and as you know its stripped to a bare shell at the minute so we have the answer somewhere buried in the dash....

I'll reflect on your question later and hopefully be back down to the car on Saturday (if I'm allowed out to play :P )

Naturally you're more then welcome to pop across and look for yourself; you can check out Ted's other Jags and his interesting collection.

Must fly - work to do - have a great sunny day!

Mike
Image
94 XJ40 S-C (Build Phase)

katar83
Distinguished Mbr
Posts: 2434
Joined: Tue Aug 23, 2011 11:17 am
Location: Cambridge

Re: Front heated windscreen

Postby katar83 » Wed Jul 06, 2016 12:12 pm

Yes, its very nice today :)

Got some more help from a jaglover in Calgary and he confirmed these are indeed sockets for the heated screen extra harness so now just need to figure out which colour should go where and 'pair' these two harnesses together with a spare plug and socket. Clearly my car was made from leftovers as the main harness is still an older version with two different plugs instead of one and a wrong part number for my VIN :roll:
1997, 4.0 LWB X300 - Unlucky car but still a daily driver.
1988, 3.6S XJS - Never ending restoration project.
1994, 3.2S X300 - Accident damaged, October 2015. Gone!
1994, 3.2S XJ40 - Long gone.

katar83
Distinguished Mbr
Posts: 2434
Joined: Tue Aug 23, 2011 11:17 am
Location: Cambridge

Re: Front heated windscreen

Postby katar83 » Sat Jul 16, 2016 3:33 pm

Success! I have retrofitted a heated windscreen to my x300. To sum it up:
I fitted in the ac panel with the extra button, then added heated windscreen from autoglass.
I still needed to plug it somewhere and as it turns out, there is an extra harness needed that plugs in to the main harness in the left side footwell. The x300 extra harness is no longer available from Jaguar(or anywhere else for that matter) so I've purchased LNB3090AA harness from XJ8. This harness has a single 4 pin plug where it suppose to join main harness and the x300 has two, two pin sockets so I've cut the 4 pin plug from the extra harness and replaced it with 2 sockets that fitted in into the main harness.
I've plugged in everything and now have switched 12V from the ac panel windscreen button and a working heated windscreen. Just need to route the cable through the bulkhead in the left side corner now :)

Extra harness:
https://goo.gl/photos/toNWSxftEKrQLbqc7

Replaced socket:
https://goo.gl/photos/TKCTS43TmTwVk3Ku6

Replaced socket in the footwell
https://goo.gl/photos/DRRjiDxafnR5gviT9
1997, 4.0 LWB X300 - Unlucky car but still a daily driver.
1988, 3.6S XJS - Never ending restoration project.
1994, 3.2S X300 - Accident damaged, October 2015. Gone!
1994, 3.2S XJ40 - Long gone.

naki_k
Super Moderator
Posts: 27631
Joined: Sun Feb 21, 2010 9:25 pm
Location: Kirton, nr Boston, Lincolnshire

Re: Front heated windscreen

Postby naki_k » Sun Jul 17, 2016 10:54 pm

Nice little upgrade. Well worth it, Especially when winter comes (though let's not think about that right now).
88 3.6 XJ6 PDH/CEM
90 Range Rover Vogue SE 3.9 V8 LPG
91 3.2 XJ6 SportPack Manual
91 4.0 XJ6 Manual
92 4.0 XJR Manual
92 4.0 XJR
93 3.2s - 4.0 Manual conv
93 4.0 Sovereign
93 6.0 XJ81 DD6
93 6.0 XJ81 XJ12
94 4.0 XJR
96 4.0 X306 XJR
96 4.0 X300 D6
97 4.0 X300 Sport Manual
2000 LR Discovery ES TD5 A
Breaking 40/ 300

katar83
Distinguished Mbr
Posts: 2434
Joined: Tue Aug 23, 2011 11:17 am
Location: Cambridge

Re: Front heated windscreen

Postby katar83 » Mon Jul 18, 2016 12:46 pm

Yeah, I guess its definitely worth it if you have to replace windscreen as the clock is not to expensive and cable can be bought for ~£20.

A few more pics, that I've posted on another Jag forum.

I've routed it here:

https://goo.gl/photos/a2nvuSLHQTByABGZ7

Cut a hole in the middle of that rubber plug. You can just about grab the cables with your hand above a yellow cable here:

https://goo.gl/photos/iQkTeg2pnproxPf28

I've bolted the earth cable here:

https://goo.gl/photos/e1udboKc16NvJchK9

Everything plugged in:

https://goo.gl/photos/Y33hLcHqG33zZQgq6

As it turned out the cable for right side of the screen is too short, I'll have to add approx 50cm of speakers cable to extend it and get to the socket but that's easier than removing the dash. Both plugs can be seen here:

https://goo.gl/photos/Cw6MddAhnefHwhao6

Tested and it all works fine.
1997, 4.0 LWB X300 - Unlucky car but still a daily driver.
1988, 3.6S XJS - Never ending restoration project.
1994, 3.2S X300 - Accident damaged, October 2015. Gone!
1994, 3.2S XJ40 - Long gone.


Return to “X-300”

Who is online

Users browsing this forum: No registered users and 1 guest