• Advertisement
Xclusively Jaguar
SNG Barratt
David Marks Garages
Make a donation to XJ40.com

Loss Of Power and Bad Smell?

Aidan
Snr Member
Posts: 622
Joined: Fri Jun 26, 2009 11:57 am
Location: Tonbridge, Kent

Re: Loss Of Power and Bad Smell?

Postby Aidan » Sat Feb 24, 2018 8:44 am

Elsa_jag wrote:I've known water in the fuel issues to come direct from the petrol pump.

Had you very recently re-fuelled prior to the problem cropping up?


No I hadn't. I filled the tank probably around two weeks ago and it has been fine since then - running almost like a new car in fact, engine wise at least.
Aidan

1994 Moroccan Red XJ40 3,2 Sport ("Ruby")
1995 Jade Green X300 3,2 Sovereign ("Jade")
2005 Cedar Green Pearl Volvo XC 90 SE

naki_k
Super Moderator
Posts: 27353
Joined: Sun Feb 21, 2010 9:25 pm
Location: Kirton, nr Boston, Lincolnshire

Re: Loss Of Power and Bad Smell?

Postby naki_k » Sun Feb 25, 2018 12:39 am

Did you check the transmission fluid? May be worth checking to see if its still pink and good or brown and mucky. It should give some clues if clutches aer being burned.
Has it ever been changed in your ownership?
88 3.6 XJ6 PDH/CEM
90 Range Rover Vogue SE 3.9 V8 LPG
91 3.2 XJ6 SportPack Manual
91 4.0 XJ6 Manual
92 4.0 XJR Manual
92 4.0 XJR
93 3.2s - 4.0 Manual conv
93 4.0 Sovereign
93 6.0 XJ81 DD6
93 6.0 XJ81 XJ12
94 4.0 XJR
96 4.0 X306 XJR
96 4.0 X300 D6
97 4.0 X300 Sport Manual
2000 LR Discovery ES TD5 A
Breaking 40/ 300

Aidan
Snr Member
Posts: 622
Joined: Fri Jun 26, 2009 11:57 am
Location: Tonbridge, Kent

Re: Loss Of Power and Bad Smell?

Postby Aidan » Sun Feb 25, 2018 9:58 pm

naki_k wrote:Did you check the transmission fluid? May be worth checking to see if its still pink and good or brown and mucky. It should give some clues if clutches aer being burned.
Has it ever been changed in your ownership?


I don't think it's been changed in my ownership, but I checked it at the transmission specialist garage just after the incident and it was full, clean, pink and had no smell. :?
Aidan

1994 Moroccan Red XJ40 3,2 Sport ("Ruby")
1995 Jade Green X300 3,2 Sovereign ("Jade")
2005 Cedar Green Pearl Volvo XC 90 SE

Aidan
Snr Member
Posts: 622
Joined: Fri Jun 26, 2009 11:57 am
Location: Tonbridge, Kent

Re: Loss Of Power and Bad Smell?

Postby Aidan » Mon Mar 05, 2018 10:55 pm

Well, it's fixed.

The cam cover gasket and plug seals were leaking and were replaced, the spark plugs were oiled up, and the crankshaft position sensor was deteriorating. The first two items were most likely the cause, but the sensor was likely contributing to the problem and there was no sign of water in the oil, no loss of water or loss of oil. So the problem appears to be fixed.

Annoyingly, I think I could have tackled all three little jobs myself had I not panicked and assumed the worst (head gasket) and had a mountain of other things to do at the same time. It was a sudden and puzzling problem that seemed to come out of nowhere. I had noticed the leaking cam cover but in my naivety I didn't think much of it :oops: .

Hey ho some you win, some you don't. At least it's fixed. Drives like it should at (legal) revs and speeds now. And as a conciliation for being a bit too eager in diving it and fixing things before advising me of the findings first, the garage replace the crumbling top radiator bushes for £0.

Thanks to "the panel" for all encouragment/ ideas/ tips etc. etc.
One day I'll start working on the red one.
Aidan

1994 Moroccan Red XJ40 3,2 Sport ("Ruby")
1995 Jade Green X300 3,2 Sovereign ("Jade")
2005 Cedar Green Pearl Volvo XC 90 SE

Morgan1
Posts: 67
Joined: Thu Dec 08, 2016 10:45 pm
Location: Aberdare, south Wales

Re: Loss Of Power and Bad Smell?

Postby Morgan1 » Tue Mar 06, 2018 8:15 am

Good news Aidan, I have a small leak on the cam cover and ordered the parts last week to renew it. I'm glad that it was a relatively cheap fix. Mine hadn't leaked on the plugs so doesn't have the same symptoms. What do you think the bad smell Was?

Craig
1992 Jaguar xj6 3.2 litre.
2016 Audi A6 S line.
2004 Volvo XC90.

Aidan
Snr Member
Posts: 622
Joined: Fri Jun 26, 2009 11:57 am
Location: Tonbridge, Kent

Re: Loss Of Power and Bad Smell?

Postby Aidan » Tue Mar 06, 2018 9:15 am

Morgan1 wrote:Good news Aidan, I have a small leak on the cam cover and ordered the parts last week to renew it. I'm glad that it was a relatively cheap fix. Mine hadn't leaked on the plugs so doesn't have the same symptoms. What do you think the bad smell Was?

Craig


Thanks Craig,

I can only assume it was old oil due to the lack of any signs of water anywhere in the engine. Other than that, I don't really know. Good luck with your gasket replacement work.
Aidan

1994 Moroccan Red XJ40 3,2 Sport ("Ruby")
1995 Jade Green X300 3,2 Sovereign ("Jade")
2005 Cedar Green Pearl Volvo XC 90 SE

Elsa_jag
Snr Member
Posts: 1077
Joined: Wed Dec 30, 2009 10:12 pm
Location: Hunnington, West Midlands

Re: Loss Of Power and Bad Smell?

Postby Elsa_jag » Tue Mar 06, 2018 10:16 am

Replacing the cam cover gasket was the first job I ever did on mine, way back in 2009. Mine leaked outwards so I had smoke from the engine bay where oil was dropping into the exhaust.

It's very much a consumable part as it is starting to crack again now.

Lucky it's a cheap and easy fix really.
Regards, Carl

ImageImage
Elsa_1994 3.2 s/ 61000 miles/ VIN 698892
http://xj40.com/viewtopic.php?f=33&t=1195


Return to “Engine”

Who is online

Users browsing this forum: No registered users and 1 guest