• Advertisement
Xclusively Jaguar
SNG Barratt
David Marks Garages
Make a donation to XJ40.com

retro fit cruise control 93 3.2

xj40 paul
Posts: 147
Joined: Fri Jun 12, 2015 8:20 pm
Location: Birmingham

Re: retro fit cruise control 93 3.2

Postby xj40 paul » Mon Apr 30, 2018 8:37 pm

Bruce69 wrote:Impatient to wait to find the location for the shorting plug I test drove it.

Unfortunately, it didn't work. There are no lights on the RH console (for the trip computer or cruise control) and failed to hold any speed; tried at 40-70 mph. (The trip computer functions as normal.)

So, does the shorting plug stop it from functioning?
Where does it fit?
Why do I have no lights on that side of the console? (the lights on the trip computer of the original console did work, so wiring to plug is ok)

Any help, greatly appreciated.

On my 1988 XJ40 I also fitted cruise control to it from scratch & found a vacant socket under the drivers side knee bolster where the shorting plug fitted , without the plug , my cruise control didn't work either & it wasn't in the kit either so it took a lot of head scratching to get it sorted . Good luck with it , regards , Paul .
Paulus The Wood Gnome .
1988 Jaguar 3.6 .
2000 Range Rover P38 DSE daily driver .

Bruce69
Posts: 24
Joined: Wed Apr 04, 2018 2:16 pm

Re: retro fit cruise control 93 3.2

Postby Bruce69 » Mon Apr 30, 2018 9:02 pm

Thanks babulio and xj40paul. I've just looked at the wiring diagrams and seeing that the shorting plug is next inline to the brake switch I thought I that I must've been looking in the wrong area. :roll:

I also noticed that the lighting was all powered by a totally separate circuit, so yes, I'll check the bulbs. I might even make and remake the connectors just to ensure there's a good connection.

I'll report back later.
XJ40 3.2 45k 1991
Jeep Grand Cherokee Overland 4.7 V8 HP LPG 2002
Merc CLK230 Kompressor LPG 2000
Dodge Charger R/T 1969

Bruce69
Posts: 24
Joined: Wed Apr 04, 2018 2:16 pm

Re: retro fit cruise control 93 3.2

Postby Bruce69 » Tue May 01, 2018 2:05 pm

Excellent, I found it. The socket for the shorting plug was right above the steering column towards the brake pedal. :P See pic below (black socket in centre):
Image

And, of course the non-lighting of the trip computer/cruise control panel ... was two blown bulbs.

Also, a correction to my removal of the instrument and console panel, you don't need to undo the black connector. This I now realise is for the steering column switches :roll:

Test drive later.
XJ40 3.2 45k 1991
Jeep Grand Cherokee Overland 4.7 V8 HP LPG 2002
Merc CLK230 Kompressor LPG 2000
Dodge Charger R/T 1969

naki_k
Super Moderator
Posts: 27415
Joined: Sun Feb 21, 2010 9:25 pm
Location: Kirton, nr Boston, Lincolnshire

Re: retro fit cruise control 93 3.2

Postby naki_k » Tue May 01, 2018 6:40 pm

Its nicely hidden away of course!
Look about half way up the back of the steering column, and there are some wires cable tied together. I think it’s two purple wires, but I will go and check.
88 3.6 XJ6 PDH/CEM
90 Range Rover Vogue SE 3.9 V8 LPG
91 3.2 XJ6 SportPack Manual
91 4.0 XJ6 Manual
92 4.0 XJR Manual
92 4.0 XJR
93 3.2s - 4.0 Manual conv
93 4.0 Sovereign
93 6.0 XJ81 DD6
93 6.0 XJ81 XJ12
94 4.0 XJR
96 4.0 X306 XJR
96 4.0 X300 D6
97 4.0 X300 Sport Manual
2000 LR Discovery ES TD5 A
Breaking 40/ 300

naki_k
Super Moderator
Posts: 27415
Joined: Sun Feb 21, 2010 9:25 pm
Location: Kirton, nr Boston, Lincolnshire

Re: retro fit cruise control 93 3.2

Postby naki_k » Tue May 01, 2018 6:41 pm

Oops, I didn’t refresh the page before replying. You found it now anyhow.
88 3.6 XJ6 PDH/CEM
90 Range Rover Vogue SE 3.9 V8 LPG
91 3.2 XJ6 SportPack Manual
91 4.0 XJ6 Manual
92 4.0 XJR Manual
92 4.0 XJR
93 3.2s - 4.0 Manual conv
93 4.0 Sovereign
93 6.0 XJ81 DD6
93 6.0 XJ81 XJ12
94 4.0 XJR
96 4.0 X306 XJR
96 4.0 X300 D6
97 4.0 X300 Sport Manual
2000 LR Discovery ES TD5 A
Breaking 40/ 300

Bruce69
Posts: 24
Joined: Wed Apr 04, 2018 2:16 pm

Re: retro fit cruise control 93 3.2

Postby Bruce69 » Tue May 01, 2018 10:58 pm

Next stumbling block is getting the cruise control to actually work . Yes, unfortunately the test drive revealed it still didn't want to work. All lights worked but still no sign of the (red?) cruise 'set' light. :(

I'm going to start going through the wiring diagram making sure I have earths and 12v where there should be. I will also give the connectors under the bonnet (for the dump valve and air pump) another going over to remove oxide layer to be sure they're good - I only used contact cleaner and made-break-and-remade the connectors. After 27 years open to the under-bonnet elements maybe a bit more work is required to clean the contacts.

Any other suggestions gratefully received.
XJ40 3.2 45k 1991
Jeep Grand Cherokee Overland 4.7 V8 HP LPG 2002
Merc CLK230 Kompressor LPG 2000
Dodge Charger R/T 1969

naki_k
Super Moderator
Posts: 27415
Joined: Sun Feb 21, 2010 9:25 pm
Location: Kirton, nr Boston, Lincolnshire

Re: retro fit cruise control 93 3.2

Postby naki_k » Wed May 02, 2018 10:03 am

Thats a shame.
That’s the right approach though. Chances are it’s a poor connection somewhere since you are not even getting the dash red light.
88 3.6 XJ6 PDH/CEM
90 Range Rover Vogue SE 3.9 V8 LPG
91 3.2 XJ6 SportPack Manual
91 4.0 XJ6 Manual
92 4.0 XJR Manual
92 4.0 XJR
93 3.2s - 4.0 Manual conv
93 4.0 Sovereign
93 6.0 XJ81 DD6
93 6.0 XJ81 XJ12
94 4.0 XJR
96 4.0 X306 XJR
96 4.0 X300 D6
97 4.0 X300 Sport Manual
2000 LR Discovery ES TD5 A
Breaking 40/ 300

NMV 1E
Snr Member
Posts: 632
Joined: Fri Apr 17, 2009 9:26 pm
Location: Lydiate, Merseyside.

Re: retro fit cruise control 93 3.2

Postby NMV 1E » Wed May 02, 2018 10:18 am

Bruce69 wrote:Next stumbling block is getting the cruise control to actually work . Yes, unfortunately the test drive revealed it still didn't want to work. All lights worked but still no sign of the (red?) cruise 'set' light. :(

I'm going to start going through the wiring diagram making sure I have earths and 12v where there should be. I will also give the connectors under the bonnet (for the dump valve and air pump) another going over to remove oxide layer to be sure they're good - I only used contact cleaner and made-break-and-remade the connectors. After 27 years open to the under-bonnet elements maybe a bit more work is required to clean the contacts.

Any other suggestions gratefully received.


From memory and pardon me, but the red light (on the console ?) ... Illuminates to indicate when the Cruise control is switched on. Setting the desired speed doesn't illuminate the red indicator ... ;)
Life begins at Forty !... I was born with nothing, I seem to have most of it left.


2006 Baby Blue Hyundai Getz 1.4 CDX (yes I know, I know, but you'd be surprised, I was !)
1989 White and Navy Blue V.W. Golf Cabriolet (G.T.i.)
1992 Tornado Red V.W. Golf "tintop" 5 door (G.T.i.)

Bruce69
Posts: 24
Joined: Wed Apr 04, 2018 2:16 pm

Re: retro fit cruise control 93 3.2

Postby Bruce69 » Fri Jun 08, 2018 1:54 pm

NMV 1E wrote:
Bruce69 wrote:Next stumbling block is getting the cruise control to actually work . Yes, unfortunately the test drive revealed it still didn't want to work. All lights worked but still no sign of the (red?) cruise 'set' light. :(

I'm going to start going through the wiring diagram making sure I have earths and 12v where there should be. I will also give the connectors under the bonnet (for the dump valve and air pump) another going over to remove oxide layer to be sure they're good - I only used contact cleaner and made-break-and-remade the connectors. After 27 years open to the under-bonnet elements maybe a bit more work is required to clean the contacts.

Any other suggestions gratefully received.


From memory and pardon me, but the red light (on the console ?) ... Illuminates to indicate when the Cruise control is switched on. Setting the desired speed doesn't illuminate the red indicator ... ;)


You're right. Having studied the wiring diagram, as soon as the Speed Control is switched on the red light should come on. I also checked all my powers and earths, which are ok. So it seems it may be a switch unit fault.

A bit more fault testing and I hope to localise the problem.
XJ40 3.2 45k 1991
Jeep Grand Cherokee Overland 4.7 V8 HP LPG 2002
Merc CLK230 Kompressor LPG 2000
Dodge Charger R/T 1969

naki_k
Super Moderator
Posts: 27415
Joined: Sun Feb 21, 2010 9:25 pm
Location: Kirton, nr Boston, Lincolnshire

Re: retro fit cruise control 93 3.2

Postby naki_k » Fri Jun 08, 2018 5:24 pm

Check the vacuum hose is fitted on the correct part of the compressor.
I have seen another owner for a cruise kit, and he was scratching his head for a while until we figured out what had gone wrong.

It should look like this.
Image

Image

Check for splits in the hoses too.
88 3.6 XJ6 PDH/CEM
90 Range Rover Vogue SE 3.9 V8 LPG
91 3.2 XJ6 SportPack Manual
91 4.0 XJ6 Manual
92 4.0 XJR Manual
92 4.0 XJR
93 3.2s - 4.0 Manual conv
93 4.0 Sovereign
93 6.0 XJ81 DD6
93 6.0 XJ81 XJ12
94 4.0 XJR
96 4.0 X306 XJR
96 4.0 X300 D6
97 4.0 X300 Sport Manual
2000 LR Discovery ES TD5 A
Breaking 40/ 300


Return to “Engine”

Who is online

Users browsing this forum: No registered users and 4 guests