• Advertisement
Xclusively Jaguar
SNG Barratt
David Marks Garages
Make a donation to XJ40.com

Engine vibrating after warm-start

XJ4081
Posts: 162
Joined: Fri Oct 23, 2015 12:12 am
Location: Germany (South-West)

Re: Engine vibrating after warm-start

Postby XJ4081 » Tue May 29, 2018 10:46 pm

Hi Starbuck,

once again many thanks for your detailed answer! I wish someone like you was around here in Germany so I could consult him, but unfortunately I haven't yet found someone with accurate knowledge and commitment.

I had expected to find some mech here that would make a list like yours and work it through, but that's obviously asked too much. If they can't use their books and reference charts or electronic diagnosis system, they are lost. At latest they run away when they hear Jaguar V12 (for some, 'Jag' is already enough). The best offer was: 'Leave it at our garage for a couple of days or a week and we we will see, what we can do about it'. I would say a Pro should be able to work through your list in half a day or one day at most, do you agree?

I will see what items of your list I can check on my own and for the others I will try to get professional support. There are two things that have already been checked/done:
- the spark plugs have been replaced recently, drove about 800km with the new ones. I could have a look at them and see if one or several of them are more or less sooty than the others.
- fuel tank and pumps have been checked last fall (because there was water in the tank), fuel pump relay had been identified as single source of error (car wouldn't start)

A stuck valve sounds serious - I hope it's not that.

Best regards
Oliver
1993 XJ12

XJ4081
Posts: 162
Joined: Fri Oct 23, 2015 12:12 am
Location: Germany (South-West)

Re: Engine vibrating after warm-start

Postby XJ4081 » Sun Jun 03, 2018 11:05 pm

Got me a stethoscope in the meantime and listened to the injectors. I heard a Tickering on all of them, maybe on one or two of them on each bank it was a little less loud but it was there. For comparison I listened at several spots within the engine bay and found the very same noise on the valve covers, probably The opening and closing of the valves. It was the same on both, cold and warm (trembling) engine. Not sure what that finally means?
1993 XJ12

pimgmx
Distinguished Mbr
Posts: 2988
Joined: Tue Jul 08, 2014 12:07 pm
Location: South East of the Netherlands

Re: Engine vibrating after warm-start

Postby pimgmx » Mon Jun 04, 2018 11:02 am

Ticking injectors is good.

I'd strongly suggest to ignore other engine sounds unless you know what you're looking for and instead use Starbuck's checklist: compression, deposit on spark plugs and those @#$%^& vacuum blanking plugs...

That'll be the best way to include causes ste-by-step.

the daily: 01 S8 http://bit.ly/2kIwP4m
the tractor: 77 LaRo LW https://bit.ly/2Hr9n6y
the eyecatcher: 93 Insignia http://bit.ly/1iGrmsU
the GT: 89 XJS http://bit.ly/1WQGpC5
the project: 95 X306 http://bit.ly/1cW11DN
the pocket rocket: 97 Z3 http://bit.ly/12IfE7B
the ex: 93 3.2 http://bit.ly/14GTNrq

XJ4081
Posts: 162
Joined: Fri Oct 23, 2015 12:12 am
Location: Germany (South-West)

Re: Engine vibrating after warm-start

Postby XJ4081 » Mon Jun 04, 2018 9:49 pm

On some injectors I thought I also heard a kind of floating (probably the fuel inside) but that was maybe only on 3 or 4.

Also got me a compression tester, but that's a bit more complicated, have to do that, when I have more spare time. Cause I will have to take out the sparks, too, I can check them at the same time.

I also measured the temperature in the engine bay with an IR thermometer, the hottest spot in the V (above the head of) had about 85°C when engine is hot (cover removed), so I think I can give that 105°C tape a chance.
1993 XJ12

XJ4081
Posts: 162
Joined: Fri Oct 23, 2015 12:12 am
Location: Germany (South-West)

Re: Engine vibrating after warm-start

Postby XJ4081 » Sun Jun 10, 2018 8:35 pm

Today I checked all of the wires and hoses in the engine bay that were accessible without disassembling stuff and except for those injector wires and amp to coil wires that I aldready had shown here, they all look and feel pretty smooth, could not find any damages or brittleness, they all seem to sit tight.

But when I lay below the car to look for other stuff, I found this lonesome red connector in front of the the lower left wheel arch. Couldn't find its counterpart anywhere. Can anyone tell me what it is good for and where I can most likely find its counterpart? I guess it measures the air flow - maybe a cause for the bad idle? But shouldn't there be an error message on the dash then?

Image
1993 XJ12

newyankee
Posts: 58
Joined: Mon Oct 06, 2014 7:32 am
Location: Hamburg, Germany

Re: Engine vibrating after warm-start

Postby newyankee » Wed Jun 13, 2018 8:10 am

From memory: Should be for the factory fog lights. Since your car doesn't have them, then the connector is open. Check on the right side, you should find another one....
--
1994 XJ12
1995 XJ12 parted out
1993 XJ6 4.0 retired for parts
1964 MkII 4.0 project
1968 TR5
2013 T-Rex 4.2 TDI

pimgmx
Distinguished Mbr
Posts: 2988
Joined: Tue Jul 08, 2014 12:07 pm
Location: South East of the Netherlands

Re: Engine vibrating after warm-start

Postby pimgmx » Wed Jun 13, 2018 11:03 am

And in general: don't be too worried about 'orphan' connectors.
You'll find quite a few more if you look closely: either for Jaguar's diagnostics systems or for options/gadgets not fitted to your car...

the daily: 01 S8 http://bit.ly/2kIwP4m
the tractor: 77 LaRo LW https://bit.ly/2Hr9n6y
the eyecatcher: 93 Insignia http://bit.ly/1iGrmsU
the GT: 89 XJS http://bit.ly/1WQGpC5
the project: 95 X306 http://bit.ly/1cW11DN
the pocket rocket: 97 Z3 http://bit.ly/12IfE7B
the ex: 93 3.2 http://bit.ly/14GTNrq

XJ4081
Posts: 162
Joined: Fri Oct 23, 2015 12:12 am
Location: Germany (South-West)

Re: Engine vibrating after warm-start

Postby XJ4081 » Wed Jun 13, 2018 3:17 pm

Hmm, remember that there was a similar Connector On the right side which was connected. Will check fog lights (I think it has them).
1993 XJ12

XJ4081
Posts: 162
Joined: Fri Oct 23, 2015 12:12 am
Location: Germany (South-West)

Re: Engine vibrating after warm-start

Postby XJ4081 » Sat Jun 16, 2018 9:54 pm

More surprise, no fog lights, but working fog light switch in the dash!? -> Maybe rear fog light.

Didn't have the time yet to check the compression, but due to some AT issues (see other thread), I had a more ambitious test drive today, experiencing max. acceleration and high speed: 0-100kph in ~ 7,4 seconds (that's about factory spec), highest speed 245kph (according to speedometer, had to stop approach due to traffic, but there was still more to come). As a layman I'd say an engine with low compression or stuck valves would not be able to deliver these values.

Maybe we can discuss another aspect we already touched: low idle rev. When engine is warm idle is only at ~650RPM, which is less than factory spec . When I increase idle rev by throttle to ~800-900RPM, the vibrations are almost gone. What are the most likely causes for low idle?
1993 XJ12


Return to “Engine”

Who is online

Users browsing this forum: No registered users and 4 guests