Page 2 of 2

Re: XJ40 4.0l crank but won't start

Posted: Thu Jan 10, 2019 10:35 am
by Elsa_jag
My car has similar issue where I seem to lose spark intermittently, makes it very hard to chase an issue down.

Does this relay exist on the 3.2? If so I’ll add it to my list of jobs to do...

Re: XJ40 4.0l crank but won't start

Posted: Thu Jan 10, 2019 1:53 pm
by cocofredo
News after compression test :
i would say compressions are in the field of a 256 000 km engine : from 6 bars to 9 ... not great . But i suspect this is not a good reason for the engine not starting ... agree ?
Obiously , engine is cold so we could imagine slighty better compressions when warm.

Cyl 1 (timing chain side)
Image

Cyl 2 :
Image

Cyl 3 :
Image

Cyl 4 :
Image

Cyl 5 :
Image

Cyl 6 :
Image

Re: XJ40 4.0l crank but won't start

Posted: Thu Jan 10, 2019 6:11 pm
by NMV 1E
They're not the worst readings I've ever seen (zero, is as low, as it gets). So no, like you suggest not a "material" reason for a none start. ;)

Re: XJ40 4.0l crank but won't start

Posted: Thu Jan 17, 2019 1:08 pm
by naki_k
cocofredo wrote:This is a 93 MY , LHD

I tried the DBC10009 yesterday , everything seems ok.

Pretty surprising , here's the situation :

- injectors are ok
- i've got sparks .

From a simple point of view , if you have sparks, fuel and air , the only thing which could affect the combustion is the compression ??

I'm afraid something went wrong inside the engine.

I'm going to perform a compression test today.


Thanks for confirming that. It makes a big difference.
I actually have a car with a similar issue, that’s just come in. I have some similar checks to you so
far. Check the earth strap in the bulkhead. They can rust away from the metal and cause none starting (bad earth). I will be refitting this today.,

Re: XJ40 4.0l crank but won't start

Posted: Thu Jan 17, 2019 9:15 pm
by Walker
As daft as it sounds, and I've nearly done it myself, make sure the distributor cap isn't on the wrong way around I.e 180 degrees. The picture in the Haynes manual has the firing order illustrated as if viewed from the n/s side of the engine, as is birds eye view of the distributor. My aftermarket blue cap has a poor alignment notch I'm sure many do.

Re: XJ40 4.0l crank but won't start

Posted: Sat Mar 16, 2019 2:27 pm
by darrenwgaransi+
Were you able to solve the problem?