• Advertisement
Xclusively Jaguar
SNG Barratt
David Marks Garages
Make a donation to XJ40.com

ANTI LOCK and Teves PUMP question!

old del boy
Distinguished Mbr
Posts: 6892
Joined: Thu Jul 10, 2008 9:29 am
Location: Kent

Re: ANTI LOCK and Teves PUMP question!

Postby old del boy » Thu Jan 10, 2019 1:49 am

The ABS light is on because you have a fault in the ABS system , this is not the cause of the pump running continuously , this could be a faulty accumulator , faulty combined pressure switch [ on top of the pump colored blue or maybe a faulty pump relay [ black base in the drivers side footwell ] .

The ABS fault no 27 [ outlet valve ] could just be a bad connection or a fault in the wiring to it or it may be stuck , the warning light just warns you the ABS is disabled , this does not affect normal brake operation these are just my opinions and what i would check but maybe you need to give this to an expert in your area .

Derek..
'93 4.0L Daimler, solent blue,
'93 4.0L Daimler, Westminster,
'85 2600 Rover sd1 vdp oporto.

swallow_che
Posts: 41
Joined: Tue Jul 24, 2018 8:16 am
Location: South Korea
Contact:

Re: ANTI LOCK and Teves PUMP question!

Postby swallow_che » Thu Jan 10, 2019 5:17 am

old del boy wrote:The ABS light is on because you have a fault in the ABS system , this is not the cause of the pump running continuously , this could be a faulty accumulator , faulty combined pressure switch [ on top of the pump colored blue or maybe a faulty pump relay [ black base in the drivers side footwell ] .

The ABS fault no 27 [ outlet valve ] could just be a bad connection or a fault in the wiring to it or it may be stuck , the warning light just warns you the ABS is disabled , this does not affect normal brake operation these are just my opinions and what i would check but maybe you need to give this to an expert in your area .

Derek..



My accumulator is new, I thought replacing the accumulator would cure this issue at the beginning. But, the problem is still existing.

So, about pressure switch.. I have searched it on internet and it seems hard to find and expensive?
(any substitution do you know?)

I might have to replace the pump relay first as it's cheaper try!
do you know which relay? I found 3 relay for ABS pump.
+ Reverse inhibit relay DAC7687
+ Main relay DAC7151
+ Relay DAC4506

This relay can cure both symptoms(ABS light and pumping continuously) this time. This is possible, right?

And could you recommend which connections and wires to look at?

There aren't any expert here in South Korea. I have visited a Jaguar official service center and a jaguar specialist who have 25years experience. But they both don't know what to do. :cry:
1990 XJ40 Daimler 4.0 VIN# 626374
(LHD, Non-LSD, Imported to South Korea)
Gunmetal Grey/Parchment
206,000 Kilometers
Daily Driver

old del boy
Distinguished Mbr
Posts: 6892
Joined: Thu Jul 10, 2008 9:29 am
Location: Kent

Re: ANTI LOCK and Teves PUMP question!

Postby old del boy » Fri Jan 11, 2019 12:20 am

I am afraid you are asking more questions than i can answer , all i can do is give you a brief idea of how you might proceed , to answer your question about the ABS light , no the relay will not cure that problem , you need to fix the fault '' 27 '' , the relay is for the pump and my manual says it is the one with the black base which it plugs in to .

As for the pressure switch there are no new ones available so you might want to search for a secondhand one , you can use this website to find part numbers

https://www.jaguarclassicparts.com/uk/j ... r-and-pump

I am sorry i cannot help you more ,

Derek..
'93 4.0L Daimler, solent blue,
'93 4.0L Daimler, Westminster,
'85 2600 Rover sd1 vdp oporto.

swallow_che
Posts: 41
Joined: Tue Jul 24, 2018 8:16 am
Location: South Korea
Contact:

Re: ANTI LOCK and Teves PUMP question!

Postby swallow_che » Fri Jan 11, 2019 10:35 am

old del boy wrote:I am afraid you are asking more questions than i can answer , all i can do is give you a brief idea of how you might proceed , to answer your question about the ABS light , no the relay will not cure that problem , you need to fix the fault '' 27 '' , the relay is for the pump and my manual says it is the one with the black base which it plugs in to .

As for the pressure switch there are no new ones available so you might want to search for a secondhand one , you can use this website to find part numbers

https://www.jaguarclassicparts.com/uk/j ... r-and-pump

I am sorry i cannot help you more ,

Derek..



You have all the answers!! helping me very much! And actually XJ40 members are all I have..

This morning, I started my xj40 and before cranking the engine ABS Pump worked a little, stopped. Meaning pressure is up and switched off I think.
(This happens sometimes..)

And abs light was gone for a second after I was running about 30km/h.

So, my guess is the Combined Pressure Switch(JLM1908) on the ABS Pump.
I just order a used one on Amazon.

I will post if this solves the problem!
1990 XJ40 Daimler 4.0 VIN# 626374
(LHD, Non-LSD, Imported to South Korea)
Gunmetal Grey/Parchment
206,000 Kilometers
Daily Driver


Return to “Wheels and Tyres”

Who is online

Users browsing this forum: No registered users and 0 guests